NetScripter is a web-based interpreter with NScripter compatibility to allow users to execute programs written with NScripter on their browsers. Learn more about NetScripter

2006-04-04 - NetScripter 0.1.5 alpha has been released. It's now able to execute encrypted script and able to run on linux server. Moreover, part of right-click menu support is added.

2006-03-15 - NetScripter 0.1.4 alpha has been released. This new version features a new graphic render which is much better when cross-fading. This version also fixed many buges appeared in 0.1.2 alpha, the caption is working again and error message is displayed instead of blank screen when script is not found.

Support of Internet Explorer 6 is also better, its support is no longer far behind from Mozilla/Firefox. The specific colour mode finally working in IE 6, the text window transparent colour is also supported now. You should really try this version if you're using Internet Explorer.

2006-02-08 - Hello, this is the first piece of news here. Opera 9 Technology Preview 2 has finally added CSS opacity support, so NetScripter is going to add support of that browser. You should be able to run some scripts with NetScripter 0.1.0 or 0.1.1, but there're some serious problem such as text is not appeared before second line is displayed, no choice appeared with select or csel command and no text sprite. The first two problems have been fixed in the latest CVS version (nscr.php 1.10 in CVS), so check it out if you're testing it with Opera 9 TP2. However, NetScripter on Opera is slow and buggy that some scripts might crash your Opera, be careful when using.

Please visit the project page for more information. Logo